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Skyline DDA Search for MS1 Filtering 

The Skyline Targeted Mass Spectrometry Environment provides informative visual displays of the raw 

mass spectrometer data you import into your Skyline documents. These displays allow you to 

manipulate the data by performing tasks such as refining the peptides and transitions you are 

measuring, and tuning integration boundaries. Originally developed to analyze quantitative assays from 

selected reaction monitoring (SRM – also referred to as multiple reaction monitoring or MRM) mass 

spectrometry, Skyline has been expanded to extract time-intensity chromatograms from MS1 spectra 

for use in peptide quantification experiments involving mass spec runs with data dependent MS/MS. 

The Skyline MS1 Full-Scan Filtering supports importing data sets from discovery-type proteomics 

experiments where mass spectrometers were operated in data dependent acquisition (DDA) mode. 

After importing the raw data, new and previously existing Skyline features facilitate quantifying peptide 

precursor MS1 signal across many replicate acquisitions. This mode may also be used for visualizing and 

better understanding quantitative outputs from other “Label Free” quantitative tools, because of the 

exceptional data visualization plots in Skyline. 

This tutorial will cover the following areas critical to making effective use of Skyline MS1 Filtering when 

you want Skyline to perform peptide spectrum matching for the MS/MS spectra in your DDA data: 

• Setting up a Skyline document for MS1 filtering 

• Performing a DDA search on raw data to find potential quantitative targets 

Skyline aims to provide a vendor-neutral platform for targeted mass spectrometry investigation. It can 

import raw data for MS1 filtering from the instrument vendors Agilent, Bruker, SCIEX, Shimadzu, 

Thermo-Scientific and Waters, making the expertise you gain here transferrable to any mass 

spectrometry lab with an instrument from one of these vendors. 

Getting Started 
To start this tutorial, download the following ZIP file: 

https://skyline.ms/tutorials/DdaSearchMs1Filtering.zip 

Extract the files in it to a folder on your computer, like: 

C:\Users\brendanx\Documents 

This will create a new folder: 

C:\Users\brendanx\Documents\DdaSearchMS1Filtering  

If you have been using Skyline prior to starting this tutorial, it is a good idea to revert Skyline to its 

default settings. To do so:  

• Start Skyline. 

https://skyline.ms/tutorials/DdaSearchMs1Filtering.zip
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• On the Start Page, click Blank Document which looks like this:  

 

• On the Settings menu, click Default.  

• Click No on the form asking if you want to save the current settings. 

The document settings in this instance of Skyline have now been reset to the default. 

Since this tutorial covers a proteomics topic, you can choose the proteomics interface by doing the 

following: 

• Click the user interface control in the upper right-hand corner of the Skyline window, and click 

Proteomics interface which looks like this:  

 

Skyline is operating in proteomics mode which is displayed by the protein icon  in the upper right-

hand corner of the Skyline window. 

You could start editing this blank document in a number of ways, but for this tutorial you will use a 

sequential set of forms called a wizard that will walk you through the steps of searching mass 

spectrometer data dependent acquisition (DDA) data files, setting up targets, and importing 

chromatograms from those files. 

Before starting the DDA search, you need to change the internal standard Skyline uses by default: 

• On the Settings menu, click Peptide Settings. 

• Click on the Modifications tab. 

• Set the Internal standard type to “none” 
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The Peptide Settings form should now look like: 

 

• Click the OK button in the Peptide Settings form. 

Searching DDA Files to Load Peptides into a Skyline Document 
You can use the Import Peptide Search wizard to run a peptide search on the MS/MS spectra in DDA 

data files. 

First, do the following to save your new document: 

• Click the Save button on the toolbar (Ctrl-S). 

• Navigate to the DdaSearchMS1Filtering folder you created for this tutorial. 

• In the File name field, enter ‘DdaSearchMS1FilteringTutorial.sky’. 

• Click the Save button. 
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Now, initiate the Import Peptide Search wizard as follows: 

• On the File menu, choose Import and click Peptide Search. 

Skyline should present a form that looks like this: 

 

In the Start from dropdown list, the Search results (build library directly) option works on the output 

from DDA search engines (e.g. pepXML files from Comet, .dat from Mascot) and the DDA raw (search 

and build library) option works on the raw data (e.g. RAW, WIFF, *.d, mzML, mzXML). The mz5 files for 

this tutorial are centroided to make them faster to download than the original profile Thermo RAW files 

produced by the mass spectrometer. 

Add the included DDA mz5 files to the search by doing the following: 

• In the Start from dropdown list, select DDA raw (search and build library). 

• Click the Add Files button. 
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• Select all the mz5 files in the DdaSearchMS1Filtering folder you created for this tutorial. 

• Click the Open button. 

The wizard form should now look like this: 

 

• Click the Next button. 
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A form should appear asking you how to handle the prefix shared by the three mz5 files:  

 

• Click the OK button. 

The wizard will advance to the Add Modifications page, where it lists all of the amino acid modifications 

in the document that you might want to include in the DDA search. It is important to distinguish here 

between fixed and variable modifications: fixed (sometimes called static) modifications are always 

applied to the specified amino acids. For example, Carbamidomethyl C is usually treated as a fixed 

modification because all cysteines in the data are expected to be alkylated. Oxidation M is almost always 

treated as a variable modification because oxidation is hit-or-miss depending on sample handling. 

Skyline’s search always treats isotopic labels as variable, but you can change whether other 

modifications are treated as fixed or variable by clicking the Edit modifications button. 
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You can also add modifications to the document from this page. Since the document was reset to 

defaults, the list starts with only Carbamidomethyl (C): 

 

These data are SILAC labelled, so you will need to add heavy label modifications here. To add them, do 

the following: 

• Click the Edit modifications button. 

• Click the Edit heavy modifications menu option. 

• Click the Add button in the Edit Isotope Modifications form. 

• In the Name field of the Edit Isotope Modification form, enter “Label:13C(6)15N(2) (C-term K)”. 

• Click the down arrow at the right side of the Name field and click the item with the same name. 

This will populate the specificity and composition fields from Unimod. 
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The Edit Isotope Modification form should now look like this: 

 

• Click the OK button 

Add a second isotope modification by doing the following: 

• Click the Add button on the Edit Isotope Modifications form. 

• From the Name dropdown list of the Edit Isotope Modification form, choose 

“Label:13C(6)15N(4) (C-term R)”. 

The 13C and 15N checkboxes are checked automatically to tell Skyline to use 13C for all carbon atoms 

and 15N for all nitrogen atoms present in an Arginine molecule, for a total mass shift of 10 Daltons (6x 13C 

+ 4x 15N). 
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The Edit Isotope Modification form should now look like this: 

 

Skyline automatically calculates both the monoisotopic and average masses, approximately 8 Daltons for 

Lysine (K) and 10 Daltons for Arginine (R) that will result from using 13C and 15N in these amino acid 

residues. To finish adding the heavy modifications: 

• Click the OK button in the Edit Isotope Modification form. 

• Click the OK button in the Edit Isotope Modifications form. 

• Check the checkboxes in the Add Modifications list for the “Label:13C(6)15N(2) (C-term K)” and 

“Label:13C(6)15N(4) (C-term R)” modifications you just created. 

Now you will add Oxidation (M) as a structural modification: 

• Click the Edit modifications button. 

• Click the Edit structural modifications menu option. 

• Click the Add button in the Edit Structural Modifications form. 

• In the Name field of the Edit Structural Modification form, enter “Oxidation (M)”. 

• Click the down arrow at the right side of the Name field and click the item with the same name. 

This will populate the specificity and composition fields from Unimod. 

• Click the OK button in the Edit Structural Modification form. 

• Click the OK button in the Edit Structural Modifications form. 

• Check the checkbox in the Add Modifications list for the “Oxidation (M)” modification you just 

created. 

• Also make sure the checkbox for “Carbamidomethyl (C)” is checked, as it should be because you 

chose the default settings. 
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At this point the Add Modifications page should look like: 

 

• Click the Next button. 

The wizard will advance to the Configure Full-Scan Settings page. 

• In the Mass Accuracy field, enter “20”. 
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The other fields on this page should default to values you can use for this tutorial, and the wizard should 

look like this: 

 

• See the MS1 Full Scan Filtering tutorial (page 9) to learn more about these settings. 

• Click the Next button. 

This should bring you to the Import FASTA page in the wizard. For this tutorial you will use a human 

protein FASTA with the sequences from Sigma-Aldrich’s Universal Proteomics Standard (UPS) prepended 

at the top (so that Skyline uses those accession numbers for any peptides that are shared between UPS 

and non-UPS proteins). To select the FASTA: 

• Click the Browse button. 

• Select the ‘2014_01_HUMAN_UPS.fasta’ file in the folder you created for this tutorial. 

• Click the Open button in the Open FASTA form. 

https://skyline.ms/_webdav/home/software/Skyline/@files/tutorials/MS1Filtering-20_1.pdf#page=9
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The wizard should now look like this: 

 

• Click the Next button. 

The wizard will advance to the Adjust Search Settings page. Here you can set the most important 

parameters for the DDA search. For this tutorial, do the following: 

• In the MS1 tolerance field, enter “5”. (Note that when you leave the text box the form will 

assume you mean ppm and set the unit box accordingly.) 

• In the MS2 tolerance field, enter “10”. 
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The form should now look like this: 

 

• Click the Next button to start the search. 
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The DDA Search page will show you the progress of the search. You may also cancel the search by 

clicking the Cancel Search button on this page. 

 

After the search is finished: 

• Click the Finish button. 
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Skyline will start to build a spectral library from the search results. After the library build is completed, a 

message box will pop up to warn you that there were some spectra that could be interpreted as multiple 

different peptides with equal confidence, and that those peptides will be ignored: 

 

• Click the OK button to dismiss the message. 

Skyline will then start to import the library into your document. When that is finished it will ask you to 

set criteria for including proteins in the document: 
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Skyline can merge proteins that match the same set of peptides into protein groups and find a minimal 

list of proteins that explain all the peptides.  You can read more about protein grouping and 

parsimonious protein inference in this documentation page: Skyline Protein Association. For this 

tutorial, leave the checkboxes for creating protein groups and finding a minimal list of proteins 

unchecked. 

• Select Assigned to first protein from the Shared peptides are: dropdown list. 

• Click the OK button. 

Configuring Skyline to View the Imported Data 
After the proteins are imported into the document, you will see the main Skyline window with the UPS 

proteins at the top of the Targets view. You should see 5,219 proteins there (counted in the status bar). 

Skyline will also begin extracting chromatograms with progress displayed in an Importing Results form. 

You can wait several minutes for chromatogram extraction to complete or you can continue with all but 

the last step below during the import. 

• Click on the [+] icon next to the third protein P01112ups|RASH_HUMAN_UPS. 

• Click on the [+] icon next to that protein’s third peptide R.TGEGFLCVFAINNTK.S. 

https://skyline.ms/wiki/home/software/Skyline/page.view?name=Skyline%20Protein%20Association%2022.1
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• Click on that peptide’s first precursor 835.9140++ and the chromatogram for that precursor and 

the MS/MS spectrum for that peptide will appear. (Note that the bold, underlined residue “C” in 

the peptide sequence indicates a carbamidomethyl cysteine).  

• If you do not see the MS/MS spectrum, on the View menu, click Library Match. 

• If you do not see as many annotated peaks in the Library Match view as in the image below, on 

the View menu, choose Ion Types and check B and Y. 

• If you do not see the entire chromatogram for the peptide, on the View menu, choose Auto-

Zoom and click None (Shift-F11). 

• Right-click the chromatogram graph, choose Peptide ID Times, and click Aligned if it is 

unchecked. 

Your Skyline window should look something like this: 

 

The document is now fully configured for MS1 Filtering with three DDA runs imported.  You will see that 

the chromatogram in this view is approximately 10 minutes in length (133 to 143 minutes), due to the 

Use only scans within [5] minutes of MS/MS IDs setting chosen in the import wizard.  Note that when 

the Skyline document is set up for MS1 Filtering, in the place where you would see product ion 

transitions (e.g. y-ions) for triple quadrupole SRM experiments, you will now see the different precursor 

isotope peaks, such as for peptide TGEGFLCVFAINNTK: precursor – 835.914++, precursor [M+1] - 

836.4154++, and precursor [M+2] – 836.9164++. 

To configure a few other features that will be helpful in general, especially to visualize certain MS1 

Filtering data, perform the following steps: 
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• On the Settings menu, make sure Integrate All is checked. 

This tells Skyline to treat all chromatograms in a peak group (here precursor ions M, M+1 and M+2) as 

integrating together, regardless of whether peaks appear to be co-eluting with the largest peak. It no 

longer impacts the integrated peak areas as it once did. 

• On the View menu, choose Peak Areas and click Replicate Comparison. 

A window with a graph like this should appear: 

 

You can dock the Peak Areas window to your desired location by doing the following: 

• Click and hold down the left mouse button, and then drag it until the mouse cursor is above the 

Library Match view. 

• When a set of 5 icons in the shape of a cross appears, move the mouse into the lower icon and 

release the left mouse button to divide the space on the right edge of the Skyline window 

between the Peak Areas and Library Match views. 

• Move the Library Match view below the Targets view by the same process. 

• On the View menu, choose Auto-Zoom and click Best Peak (F11). 

• On the View menu, choose Arrange Graphs and click Column. 

• Right-click a chromatogram graph, and click Legend to turn off the legend in the chromatogram 

graphs. 
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Now your Skyline window should look something like this: 

 

From this point you can learn more about working with DDA data by consulting the MS1 Full Scan 

Filtering tutorial. 

https://skyline.ms/_webdav/home/software/Skyline/@files/tutorials/MS1Filtering-20_1.pdf
https://skyline.ms/_webdav/home/software/Skyline/@files/tutorials/MS1Filtering-20_1.pdf

