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Skyline Small Molecule Multidimensional 
Spectral Libraries 

In this tutorial, you will learn how to utilize spectral libraries and drift time filtering for analysis of 

complex ion mobility spectrometry-mass spectrometry (IMS-MS) small molecule data. The Skyline IMS-

MS capabilities are compatible with platforms where collision cross section (CCS) values are calculated 

such as DTIMS, TIMS, and TWIMS instruments. (Skyline also supports FAIMS ion mobility filtering, 

though that is not covered here.) A spectral library containing m/z, retention time, fragmentation, and 

ion mobility information for a set of lipids in fruit fly samples will be explored and added to a Skyline 

document. The CCS values for each molecule can then be used to increase the selectivity of precursor 

and fragment extracted ion chromatograms above what can be realized by high mass resolution alone, 

thereby reducing interference from other ions. 

In this more advanced tutorial, some familiarity with Skyline is assumed.  If you are not familiar with 

Skyline, you should first work through some of the introductory tutorials at 

http://skyline.ms/tutorials.url 

Getting Started 

To start this tutorial, download the following ZIP file: 

https://skyline.ms/tutorials/SmallMoleculeLibraries.zip 

There is a total of over 2 GB of data, so downloading may take a while. 

Extract the files in it to a folder on your computer, like: 

C:\Users\bspratt\Documents 

This will create a new folder: 

C:\Users\bspratt\Documents\SmallMoleculeLibraries 

It will contain the Skyline files necessary for this tutorial.  

The .d folders contain data from a male (M) and female (F) fruit fly (Drosophila melanogaster) lipid 

extract. 

If you have been using Skyline prior to starting this tutorial, it is a good idea to revert Skyline to its 

default settings. To do so:  

 Start Skyline. 

http://skyline.ms/tutorials.url
https://skyline.ms/tutorials/SmallMoleculeLibraries.zip
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 On the Start Page, click Blank Document which looks like this:  

 

 On the Settings menu, click Default.  

 Click No on the form asking to save the current settings. 

The document settings in this instance of Skyline have now been reset to the default. 

Since this tutorial covers a small molecule topic, you can choose the molecule interface by doing the 

following: 

 Click the user interface control in the upper right-hand corner of the Skyline window, and click 

Molecule interface which looks like this:  

 

Skyline is operating in molecule mode, as indicated by the molecule icon  in the upper right-hand 

corner of the Skyline window.  Skyline’s proteomics-specific menus and controls are now hidden, 

allowing you to focus on small molecule analysis. 

Transition Settings 
You will need to review the transition settings before adding the spectral library and results data. 

To do this, perform the following steps: 

 On the Settings menu, click Transition Settings. 

 Click the Filter tab. 

The transition filter settings are used to decide which library entries are suitable for inclusion in the 

Skyline document. Only entries with adducts that match the filters will be selected for use. 

 In the Precursor Adducts field, enter “[M-H], [M+HCOO], [M+CH3COO]”. 
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 In the Fragment Adducts field, enter “[M-]”. 

 This data was collected in negative ionization mode so [M+H] and [M+] can be removed from 

the Precursor Adducts and Fragment Adducts fields if you see them there. However, they are 

harmless if left as is since the library that will be used has only negative ion mode entries. 

These adducts can also be added using the drop-down menus accessed by the arrow buttons. Navigate 

to the Adducts- menu, and select the appropriate adducts. 

 In the Ion Types field, enter “f,p” to include both fragments and precursors in the filter. 

The Transition Settings form should now look like this: 

 

 Click the Full-Scan tab in the Transition Settings form. 
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 In the MS1 filtering section, set the Isotope peaks included field to Count. 

 Set the Precursor mass analyzer field to TOF. 

 In the Resolving power field, enter “20,000”. 

 In the MS/MS filtering section, set the Acquisition method field to DIA. 

 Set the Isolation scheme field to All Ions. 

 In the Resolving power field, enter “20,000”. 

 Check Use high-selectivity extraction. 

The Transition Settings form should look like this: 

 

The Transition Settings form instructs Skyline to extract 3 precursor isotope peaks from MS1 (low-

energy) spectra and fragment ions from MS/MS (high-energy) spectra acquired at ~28,000 resolving 
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power on a TOF instrument. Utilizing lower 20,000 resolving power accounts for the difference in 

resolving power between ions of different concentrations. The acquisition method “DIA” and isolation 

scheme “All Ions” indicate to Skyline that the spectra are alternating low- and high-energy without 

precursor isolation. When Use high-selectivity extraction is checked, Skyline extracts a single resolution 

width around the target m/z, and when it is unchecked Skyline extracts 2x the resolution width, which 

should increase the total number of ions included in the extraction but at the risk of increasing 

interference.  

The Prediction tab does not apply to this tutorial and the Library and Instrument tabs have acceptable 

defaults. The Ion Mobility tab will be revisited later in the tutorial. 

 Click the OK button. 

Adding and Exploring a Spectral Library 
Before you can explore the library, Skyline must be directed to its location by adding your library of 

interest to the global list of libraries for document editing. The library used in this tutorial was created in 

Skyline from experimental data and a transition list generated by LipidCreator. 

To get started with the small molecule library containing Drosophila lipids perform the following steps: 

 From the Settings menu, click Molecule Settings. 

 Click the Library tab. 

 Click the Edit List button. 

 Click the Add button in the Edit Libraries form. 

 In the Name field of the Edit Library form, enter “Drosophila Lipids”. 

 Click the Browse button. 

 Navigate to the SmallMoleculeLibraries folder created earlier. 

 Select the “Drosophila_Lipids_Neg.blib” file. 

 Click the Open button. 

 Click the OK button in the Edit Library form. 

 Click the OK button in the Edit Libraries form. 

The Libraries list in the Molecule Settings form should now contain the Drosophila Lipids library you just 

created. 

 Check the “Drosophila Lipids” checkbox to include this library in the current document. 

 If you have any other libraries in this list checked, uncheck them now. 

https://skyline.ms/skyts/home/software/Skyline/tools/details.view?name=LipidCreator
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The Molecule Settings form should now look like this: 

 

 Click the OK button in the Molecule Settings form. 

To open the library explorer and view the contents of the library you just added, do the following:  

 From the View menu, click Spectral Libraries. 
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The library explorer should now look like this: 

 

On the left side of the explorer, the Library list illustrates that you are currently viewing the 

Drosophila_Lipids library. The Molecule list below it shows the lipid common names and adducts which 

have been matched to the spectra in this library. The <<Previous and Next>> buttons are disabled for 

this library, because all of its spectra can be listed in a single page. At the very bottom, the library 

explorer reports that the page contains 1 through 38 of a total 38 molecule spectrum matches. 

Hover your cursor over any molecule, and Skyline will display the name, formula, and precursor m/z.  

To narrow the list of molecules with the molecule filter box, do the following: 

 Click in the text box above the Molecule list. 

 Enter “PG”. 

The library explorer will display all phosphatidylglycerol (PG) lipids in the library. In this case, the list is 

reduced to four PG lipids. 

Turning your attention to the right side of the library explorer, you will see a Skyline MS/MS spectrum 

similar to the one Skyline displays during document editing, and in fact this chart supports most of the 

same features. To explore a few of these features, take note of the following: 

 On the right-side toolbar, the f and 1 buttons should be pushed to show charge 1 fragment ions. 

In this library, there are no charge 2 ions.  
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 The retention time (RT), collision cross section (CCS) and the ion mobility spectrometry (IMS) 

drift time value are displayed underneath each spectrum. 

 Notice that the toolbar also contains buttons to Copy, Save, and Print the current chart, and as 

with most charts in Skyline, further options can be accessed through a right-click menu. 

To add all the molecules in the library to your target list: 

 Click the Add All button. 

A popup window will then notify you that this will add 34 molecules, 38 precursors, and 246 transitions 

to the document. 

 Click Add All. 

 Click the Close button on the Spectral Library Explorer form. 

Your Skyline window should now look like this: 

 

Importing Results Data 
In this section, you will import the Drosophila data without utilizing IMS filtering. This is an initial look at 

the data to see the impact of interference among lipids and their shared fragments. To import the data, 

perform the following steps: 
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 On the File menu, click Save (Ctrl+S). 

 Save this document in the tutorial folder you created. 

 From the File menu, choose Import and click Results. 

 Set the Files to import simultaneously field to Many. 

 Check Show chromatograms during import. 

The Import Results form will appear as follows: 

 

 Click the OK button. 
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The Import Results Files form will now show the .d files you have extracted into the tutorial folder: 

 

 Select both .d files. 

 Click the Open button. 

 The Import Results window will ask if you would like to remove the common prefix and suffix to 

shorten the file names used in Skyline. Click OK to accept the names “F_A_018” and 

“M_A_001”. 
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This should start the import and cause Skyline to show the Importing Results progress form: 

 

Reviewing the Extracted Ion Chromatograms 
Once the files are imported, you can examine the chromatograms to evaluate interference from peaks 

with retention times and m/z values within the tolerance of your target list. 

 From the Edit menu, choose Expand All and click Molecules (Ctrl+D). 

 From the View menu, choose Arrange Graphs and click Tiled (Ctrl+T). 

 Right-click in a chromatogram graph and click Synchronize Zooming (leave if already checked). 

 Right-click in a chromatogram graph and click Legend to hide the legend. 

 Right-click in a chromatogram graph, choose Transitions and click Split Graph (leave if already 

checked). 

 In the Targets view, select the molecule PC(16:0_18:1). 

 On the View menu, choose Auto-Zoom and click Best Peak (F11). 

To see a bit more of the gradient time range, do the following: 

 Right-click in a chromatogram graph and click Properties. 

 Uncheck Peak width relative. 

 In the Best peak time range field, enter “7” minutes. 

 Click the OK button. 



12 
 

Your chromatogram graphs should appear as follows: 

 

Note that while the precursor extracted ion chromatogram (XIC) is clean, the transitions for FA 16:0(+O) 

and FA 18:1(+O) are highly abundant across a large portion of their XICs. This is due to the nature of lipid 

fragmentation, as most lipids with 16:0 or 18:1 fatty acyl chains will share those same fragments. Similar 

results will be observed for each lipid you select, especially the other phospholipids (PC, PE, PG, PI).  

Since there are only 38 precursors in this document, you may want to review all 38 to get an overall feel 

for how the XICs look prior to IMS filtering. Before starting this review, do the following: 

 In the Targets view, select the first precursor Cer(d14:1/20:0) - 596.5259[M+CH3COO]. 

 Double-click the Library Match title bar to float it above the main window. 

 Adjust the size of the floating Library Match window. 

 Click and drag in the Library Match spectrum graph region roughly from 100 to 400 m/z. 
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This should leave the Library Match view showing an MS/MS spectrum like this: 

 

 Attach the Library Match view beneath the Targets view by clicking in the title bar and 

dragging over the Targets view until the mouse cursor is inside the bottom docking icon. 

 On the View menu, choose Retention Times and click Replicate Comparison (F8). 

 Attach the Retention Times view to the right edge of the main window by clicking in the 

title bar and dragging until the mouse cursor is inside the right-side docking icon. 

 Right-click in the Retention Times view and click Legend to hide the legend in this graph. 

 From the View menu, choose Peak Areas and click Replicate Comparison (F7). 

 Attach the Peak Areas view to the left of the Retention Times view by clicking in the title bar 

and dragging over the Retention Times view until the mouse cursor is inside the left side 

docking icon. 

 Adjust the view sizing using the splitter bar regions between them. 
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You should end up with a similar layout to the one shown below: 

 

To adjust the zooming on the chromatogram graphs: 

 Click one of the chromatogram graphs and use the mouse or touchpad to scroll (using a scroll-

wheel or two-fingers respectively). 

Skyline often does a good job picking peaks and most integration boundaries do not need to be edited. 

However, there are a few isomer pairs that require some manual adjustment to the default integration. 

The first two cases are the lysophospholipids (LPC and LPE), which are phospholipids with one fatty acyl 

chain cleaved off. These molecules chromatographically separate depending on the sn- position of the 

single fatty acyl chain. Here the library match ID retention time markers can be utilized to determine the 

elution order of the LPC(0:0/18:2)/LPC(18:2/0:0) and LPE(0:0/16:0)/LPE(16:0/0:0) pairs.  

 Drag the integration boundaries with your mouse to integrate the correct peaks. Or click and 

drag beneath the x-axis. 

Note that male and female fruit flies have vastly different lysophospholipid profiles, which was also 

observed across almost all lysophospholipids in a larger Drosophila study. 

The final isomer pair is near the bottom of the document. PG(16:0_18:3) and PG(16:1_18:2) have 

different fatty acyl compositions, but the same total number of carbons and double bonds, causing them 

to share the same precursor formula and m/z value.  



15 
 

 Again, use the library match ID retention time markers to determine the correct peak for each 

lipid.  

 To integrate the correct peaks, either drag the integration boundaries with your mouse or click 

the retention time label above the peak apex.  

The product XIC may not be useful until IMS filtering is utilized. 

Understanding and Utilizing the IMS Separation 
To this point, the IMS dimension in this data has been ignored. To better understand the IMS separation, 

you need to look at the underlying spectra from which these chromatograms were extracted by doing 

the following: 

 Right-click in a chromatogram graph and click Properties. 

 Check Peak width relative. 

 In the Best peak time range field, enter “3.4” widths. 

 Click the OK button. 

 Select the molecule PE(16:1_18:3) in the Targets view. 

 Hover the mouse cursor over the precursor chromatogram peak apex until a blue circle appears 

that tracks the mouse movement, and click on it. 
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This should bring up the Full-Scan view showing a familiar two-dimensional spectrum in profile mode: 

 

 Click the Show 2D Spectrum button  to change the plot to a three-dimensional spectrum 

with drift time. 
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You can see that there is a small interference above the most intense visible ion.  

 Take a closer look by placing your cursor in the center of the plot and use the scroll-wheel (or 

two fingers on a trackpad) mouse-centered zooming to zoom in. You can also place your cursor 

to the left of the y-axis or below the x-axis to zoom one axis only. 

These two ions are well-separated by IMS with the most intense ion below 34 ms and the interference 

above 36 ms. 

 Click the Zoom to Selection button to see the entire 3D MS1 spectrum. 

 

This is a fairly typical MS1 spectrum for IMS-MS lipidomics data. You can get a better sense of the data 

by zooming into multiple areas on this plot. You can also select other lipids and click on the blue circle at 

the apex of each precursor chromatogram peak to see how this plot can differ with retention time. An 

interesting example is PE(O-18:0/16:1), which has distinct ion distributions showing correlations 

between m/z and drift time for different lipid classes. 

To inspect a relevant MS/MS spectrum: 

 Re-select the molecule PE(16:1_18:3) if you navigated away from it to view other MS1 spectra. 

 Click on the Zoom to Selection button to zoom back in. 

 Hover the mouse over the FA 18:3(+O) fragment chromatogram peak apex until a teal colored 

circle appears that tracks the mouse movement, and click on it. 
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The Full-Scan graph should change to: 

 

You can see that at least three visible ions are contributing to the extracted intensities at 33, 37, and 44 

ms. This goes back to the nature of lipid fragmentation as previously discussed, where most lipids with 

an 18:3 fatty acyl chain will share this fragment. The complexity is increased for fatty acyl chains 

fragments with fewer double bonds, such as 18:2 at m/z 279, which may have multiple ions as well as 

isotopic overlap from the abundant 18:3 fragment at m/z 277 contributing to the extracted intensity. A 

similar observation can be made with the FA 16:1(+O) fragment. 
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 Click the Zoom to Selection button again to see the entire 3D MS/MS spectrum. 

 

This is also a typical IMS-MS/MS spectrum, where you can imagine each horizontal stripe as a top-down 

view of a normal 2D spectrum. Clearly, there are many signals in this 3D space other than the one at 34 

ms. 

Reimporting Data with Drift Time Filtering 
It should now be clear that the selectivity of chromatogram extraction in MS/MS and even MS1 can be 

improved by utilizing IMS and extracting only a limited drift time range around the area of interest. 

Skyline can learn and apply the IMS drift times directly from the results data, which is explained in detail 

in the Training a Drift Time Predictor section of the Skyline Ion Mobility Spectrum Filtering tutorial. In 

this tutorial, however, you may recall that the spectral library contains collision cross section (CCS) 

values for each molecule, which can now be use to extract only limited drift time ranges for additional 

identification confidence and selectivity. 

Prior to changing the settings and reimporting the data, you may want to save the current Skyline 

document and create a second file in order to compare the data before and after IMS filtering. To do so: 

 On the File menu, click Save (ctrl-S) to make sure any changes are saved to the original. 

 On the File menu, click Save As... 

 Save the file with a different name than your original Skyline document, such as 

“Drosophila_Lipids_Neg_IMS_Filtered”, in the tutorial folder you created. 

https://skyline.ms/tutorial_ims.url
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The data files have been single field calibrated using vendor software, meaning Skyline can easily 

convert between drift time and CCS. CCS values are normalized and reproducible, allowing the use of 

previously determined CCS (from databases and standards) to filter the data. To utilize the IMS 

information stored in the library, perform the following steps: 

 From the Settings menu, click Transition Settings. 

 Click the Ion Mobility tab. 

 Check Use spectral library ion mobility values when present. 

 Set the Window Type field to Resolving power. 

 In the Resolving power field, enter “50”. 

The Transition Settings should now look like this: 
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 Click the OK button. 

The results must now be reimported with the newly applied IMS settings as follows: 

 From the Edit menu, click Manage Results. 

 Use ctrl-click or click-and-shift-click to multiple select both replicates. 

 Click the Re-import button. “*” Should appear to the left of both names. 

 Click the OK button. 

This should start the re-import and cause Skyline to show the Importing Results progress form. When 

the import has completed: 

 Click any other lipid in the Target list and re-select PE(16:1_18:3) to update the chromatograms. 

To explore the filtered data, perform the following steps: 

 Click on the apex of the blue precursor chromatogram to show the Full-Scan graph. 

 Click the Zoom to Selection button. 

The Full-Scan graph should now look something like this: 

 

The horizontal violet range showing the filter imposed by the CCS (261 Å2) is now visible and stored in 

the Skyline document. The signal outside of this drift time range has been ignored by Skyline during 

chromatogram extraction. Therefore, the interference at 36 ms has been removed. To view the filtered 

MS/MS data: 
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 Click on the apex of the teal and orange fragment chromatograms. 

You may notice that the fragment ions have slightly lower drift times than the precursor. This occurs 

because the voltage applied in the collision cell causes the smaller fragment ions to have a higher 

velocity and arrive at the detector slightly faster than the larger precursor ions. This is accounted for by 

adding high energy drift time offset values to the spectral library. 

Select other targets to compare the current chromatograms to those observed prior to drift time 

filtering. To further investigate the filtering of interferences, click on the apex of the precursor and 

fragment peaks. 

Note that if you were interested in lipids that are not present in the current spectral library, you can add 

to it manually or using LipidCreator. To access the LipidCreator plugin, do the following: 

 From the Tools menu, click Tool Store. 

 Select LipidCreator in the list of available tools. 

 

 Click the Install button. 

A progress form should appear as LipidCreator is downloading. When it finishes, LipidCreator can be 

accessed directly from the Tools menu. 



23 
 

The following steps can be taken to easily export an updated spectral library once you have an expanded 

set of results for new lipids of your choosing: 

 From the File menu, choose Export and click Spectral Library. 

 Enter a file name and click Save. 

Conclusion 
In this tutorial, you have learned how to work with small molecule spectral libraries and IMS data in 

Skyline. You now understand the settings required for chromatogram extraction from this type of data. 

You can import, export, and inspect the contents of any small molecule spectral library. You have 

learned to interpret the alternating MS1 and MS/MS three-dimensional spectra produced by an IMS 

enabled mass spectrometer for complex lipidomics datasets. You can now use CCS values for drift time 

filtering to enhance the selectivity of chromatograms extracted by Skyline. Having completed this 

tutorial, you should be ready to take full advantage of multidimensional spectral libraries to improve 

your analysis of small molecules. 


